Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: satchmo Date: Jun 6, 2007 11:31pm
Forum: etree Subject: Re: derivations problems on an upload

I had to go back to an older version of FLAC, was having the same problems when I built up a new audio work station and downloaded the latest version. Couldn't figure out what I was doing wrong. Last show I uploaded was with the old version of FLAC and no problems. I will go back and fix the 2 other shows with the same problem as you using the older version of the software.

There was an error that came up when I ran the derivatives that even mentioned that the error was likely related to the use of the more recent releases of FLAC.

Only way to truly put this to rest is to use both versions of FLAC on the same file and run the derivatives and see what happens. It's on my long list of things to do!

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffBrad Leblanc Date: Jun 7, 2007 9:36am
Forum: etree Subject: Re: FLAC Version Compatibility

I had to go back to an older version of FLAC, was having the same problems when I built up a new audio work station and downloaded the latest version.

Just want to correct this misinformation to avoid confusion:

The version of FLAC you use has nothing to do with problems with your upload (unless you are using a *very* old copy of FLAC). The version we use on our deriver machines (1.1.2) is 100% forward compatible with the current version (1.1.4) and I confirmed this on the FLAC mailing list.

There was an error that came up when I ran the derivatives that even mentioned that the error was likely related to the use of the more recent releases of FLAC.

This information is incorrect as well. Again, the version we use is 100% compatible with the newest version of FLAC. Files encoded with 1.1.4 will upload, verify and decode without any issues. I have been using 1.1.4 with no issues and recently uploaded a recording that worked fine.

-Brad

This post was modified by Brad Leblanc on 2007-06-07 16:34:00

This post was modified by Brad Leblanc on 2007-06-07 16:36:16

Reply to this post
Reply [edit]

Poster: satchmo Date: Jun 7, 2007 9:58am
Forum: etree Subject: Re: FLAC Version Compatibility

I still would like to take a master .wav file and create one flac using the newest version and another flac using an older version. This is the message I picked off one of the shows that I uploaded that contained an error. This same show was bit torrented from the same file set as the upload with no errors. http://bt.etree.org/details.php?id=505579

I'm human and could be making a mistake uploading but I haven't been able to find any errors in my ftp config or errors with other uploads. This Franti show http://www.archive.org/details/mfs2007-05-26 was transferred and uploaded using the same methods except for the use of the older version of FLAC

Thanks for everything you guys do!

Here is the copy and pasted message I got when I derived the files in question.

The FLAC stream may have been created by a more advanced encoder. Try metaflac --show-vendor-tag nrps2006-12-08d2t06.flac If the version number is greater than 1.1.2, this decoder is probably not able to decode the file. If the version number is not, the file may be corrupted, or you may have found a bug. In this case please submit a bug report to http://sourceforge.net/bugs/?func=addbug&group_id=13478 Make sure to include an email contact in the comment and/or use the "Monitor" feature to monitor the bug status.

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffBrad Leblanc Date: Jun 7, 2007 1:27pm
Forum: etree Subject: Re: FLAC Version Compatibility

satchmo - please post a link to this NRPS show.

Reply to this post
Reply [edit]

Poster: satchmo Date: Jun 8, 2007 12:28pm
Forum: etree Subject: Re: FLAC Version Compatibility

It went too long without being fixed so it was "made dark" after looking for it in my contribution center links.
Thanks for maintaining this beast!

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or Staffgreenone Date: Jun 7, 2007 7:47am
Forum: etree Subject: Re: derivations problems on an upload

Looks like it's fixed now...thanks to Ed (chops11).

Reply to this post
Reply [edit]

Poster: robclarke Date: Jun 7, 2007 10:00am
Forum: etree Subject: Re: derivations problems on an upload

yes it is fixed thanks to whoever did it